git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help with bad errors on 4.6.1


I've asked enrico to run again, as this dump doesn't span the time
when the issue started occurring.
What I'm looking for is to be able to inspect the first packet which
triggers the version downgrade of the decoders.


On Fri, Mar 9, 2018 at 3:04 PM, Enrico Olivelli <eolivelli@xxxxxxxxx> wrote:
> This is the dump
>
> in order to reproduce the issue I did these steps:
> - all bookies with 4.1.12
> - start reader with netty 4.1.21 -> still no issue
> - start on bookie with 4.1.21 -> start issue
> - bookie again with 4.1.12 -> client messed up, unrecoverable
>
> a strange fact is that I cannot find IllegalReferenceCount errors on bookies
>
> I will try different combinations in order to create a simpler reproducer
>
> that you for you help