git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Python 3 incompatibility


Python 3 support for Apache Beam is still in the works. https://issues.apache.org/jira/browse/BEAM-1251


On Mon, Mar 19, 2018 at 1:51 PM Driesprong, Fokko <fokko@xxxxxxxxxxxxxx> wrote:
Hi all,

I'm working Apache Airflow and we have some issues with google-cloud-dataflow 2.3.0 and Python 3.0. We've noticed that the new package isn't compatible with Python 3.

Collecting apache-beam[gcp]==2.3.0 (from google-cloud-dataflow==2.3.0)

  Could not find a version that satisfies the requirement apache-beam[gcp]==2.3.0 (from google-cloud-dataflow==2.3.0) (from versions: 0.6.0, 2.0.0, 2.1.0, 2.1.1, 2.2.0)

No matching distribution found for apache-beam[gcp]==2.3.0 (from google-cloud-dataflow==2.3.0)


We also got some reports on Stackoverflow:

What are your thoughts on this? Are you discontinuing support of Python 3? Please let me know.

Kind regards,
Fokko Driesprong
Apache PPMC Member & Apache Airflow committer



( ! ) Warning: include(msgfooter.php): failed to open stream: No such file or directory in /var/www/git/apache-beam-users/msg02076.html on line 86
Call Stack
#TimeMemoryFunctionLocation
10.0009368648{main}( ).../msg02076.html:0

( ! ) Warning: include(): Failed opening 'msgfooter.php' for inclusion (include_path='.:/var/www/git') in /var/www/git/apache-beam-users/msg02076.html on line 86
Call Stack
#TimeMemoryFunctionLocation
10.0009368648{main}( ).../msg02076.html:0