git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[jira] [Commented] (ARIES-1739) Specifiying a version in Require-Capability prevents registration


    [ https://issues.apache.org/jira/browse/ARIES-1739?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16674520#comment-16674520 ] 

ASF subversion and git services commented on ARIES-1739:
--------------------------------------------------------

Commit 1845748 from rotty3000@xxxxxxxxxx in branch 'aries/trunk'
[ https://svn.apache.org/r1845748 ]

ARIES-1857 Regression in framework.extension due to work on ARIES-1739

Signed-off-by: Raymond Auge <rotty3000@xxxxxxxxxx>

> Specifiying a version in Require-Capability prevents registration
> -----------------------------------------------------------------
>
>                 Key: ARIES-1739
>                 URL: https://issues.apache.org/jira/browse/ARIES-1739
>             Project: Aries
>          Issue Type: Bug
>          Components: SPI Fly
>    Affects Versions: spifly-1.0.8
>            Reporter: Michael Lipp
>            Assignee: Raymond Augé
>            Priority: Major
>             Fix For: spifly-1.1.1
>
>
> The OSGi Compendium 6.0.0 provides an example for specifying a provider:
> Require-Capability:
>     osgi.extender;
>     filter:="(&(osgi.extender=osgi.serviceloader.processor)
>     (version>=1.0)(!(version>=2.0)))"
> This fails with spi-fly because spi-fly doesn't provide a version attribute when filtering the requirements, only the type (ProviderBundleTrackerCustomizer:390).
> The example in the spi-fly documentation does not include the version in the filter. But it does also not warn you that adding it makes things fail. Having read the compendium specification first, you wouldn't expect that specifying the filter has this fatal effect.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)