git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Antlib SVN and antunit Java versions


While looking at some of our Jenkins jobs, to reconfigure them to use
gitbox (wherever necessary), I notice that there are 2 jobs[1][2] which
are for Antlib SVN and Antunit libraries. Both these jobs are configure
for JDK 5, because those projects target Java 5 as the minimal runtime.
However, the Maven central repo, from which we fetch certain
dependencies during build has been configured not to let clients with
lower TLS versions (lesser than TLSv1.2) to communicate with it. As a
result they are now failing. The issue has been around for a while with
these jobs, it's just that they haven't run for a few months until
yesterday.

One option in similar cases that we have employed in other jobs is to
configure the Java system property -Dhttps.protocols to "TLSv1.2". But
this version of TLS is only supported in a Java release after Java 1.5.
In short, unless we upgrade the Java runtime version of these jobs (or
do some very specific tricks to use a different Java version while
pulling down the dependencies in the build), they will continue failing.

At a more higher level, I think it's probably time to decide whether we
want to change the minimum required Java versions for these libraries?
Should we now mandate Java 1.8 at least?


[1] https://builds.apache.org/job/AntLib-svn/

[2] https://builds.apache.org/job/AntLib-antunit/


-Jaikiran



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxx
For additional commands, e-mail: dev-help@xxxxxxxxxxxxxx