git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AW: Jenkins-Builds failing


Neither do I.

Jan

> -----Ursprüngliche Nachricht-----
> Von: Jaikiran Pai [mailto:jai.forums2013@xxxxxxxxx]
> Gesendet: Freitag, 20. Juli 2018 10:15
> An: dev@xxxxxxxxxxxxxx
> Betreff: Re: Jenkins-Builds failing
> 
> Now that I checked the job's logs, I think that's true. We had this
> issue in Ant too (not really against Maven repos, but HTTPS hosted
> Apache infrastructure). I tried setting that property in the job, but I
> too don't have the necessary authorization. I don't remember if I ever
> had those permissions or if it's something that changed with the recent
> Jenkins upgrade.
> 
> -Jaikiran
> 
> 
> On 20/07/18 1:34 PM, Gintautas Grigelionis wrote:
> > My hypothesis is that Java 7 must have TLS version forced to 1.2 in
> > order to avoid protocol errors when downloading new binaries from
> > Maven Central because earlier versions are disabled [1] (and TLS 1.0
> > is the default in Java 7).
> >
> > Gintas
> >
> > 1.
> > https://blog.pcisecuritystandards.org/are-you-ready-for-30-june-2018-
> s
> > ayin-goodbye-to-ssl-early-tls
> >
> > On Fri, 20 Jul 2018 at 09:31, Jaikiran Pai <jai.forums2013@xxxxxxxxx>
> wrote:
> >
> >> Haven't checked the job, but why is this system property required to
> >> be set?
> >>
> >> -Jaikiran
> >>
> >>
> >> On 20/07/18 12:51 AM, Gintautas Grigelionis wrote:
> >>> I'd like to add a Java option to Ivy builds
> >>> -Dhttps.protocols=TLSv1.2
> >> but I
> >>> get
> >>> This job's current authorization strategy does not permit gintas to
> >> modify
> >>> the job configuration
> >>>
> >>> Gintas
> >>>
> >>> On Tue, 3 Jul 2018 at 19:09, Gintautas Grigelionis <
> >> g.grigelionis@xxxxxxxxx>
> >>> wrote:
> >>>
> >>>> Ant nightly is stuck on archiving for 30 hours now.
> >>>> It should be escalated, I believe that could have something to do
> >>>> with
> >> the
> >>>> last upgrade of Jenkins.
> >>>>
> >>>> Gintas
> >>>>
> >>>> On Mon, 2 Jul 2018 at 14:18, Jan Matèrne <jan@xxxxxxxxxx> wrote:
> >>>>
> >>>>> Several of our Jenkins builds are failing:
> >>>>>
> >>>>>
> >>>>>
> >>>>> IvyDE:
> >>>>>
> >>>>> https://builds.apache.org/view/A/view/Ant/job/IvyDE/
> >>>>>
> >>>>>
> https://builds.apache.org/view/A/view/Ant/job/IvyDE/lastBuild/cons
> >>>>> ole
> >>>>>
> >>>>> Can't get
> >>>>>
> >>>>>
> >> http://download.eclipse.org/webtools/downloads/drops/R3.4.2/R-3.4.2-
> 2
> >> 0130208
> >>>>> 151217/wtp4x-R-3.4.2-20130208151217.zip
> >>>>> <
> >> http://download.eclipse.org/webtools/downloads/drops/R3.4.2/R-3.4.2-
> 2
> >> 0130208151217/wtp4x-R-3.4.2-20130208151217.zip
> >>>>> to
> >>>>>
> >>>>>
> >> /home/jenkins/jenkins-slave/workspace/IvyDE/dependencies/wtp4x-R-
> 3.4.
> >> 2-20130
> >>>>> 208151217.zip
> >>>>>
> >>>>>
> >>>>>
> >>>>> The source URL gives a 404.
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>> AntLib - AntUnit
> >>>>>
> >>>>> https://builds.apache.org/view/A/view/Ant/job/AntLib-antunit/
> >>>>>
> >>>>>
> >>>>>
> >> https://builds.apache.org/view/A/view/Ant/job/AntLib-
> antunit/lastBuil
> >> d/conso
> >>>>> le
> >>>>>
> >>>>> [ivy:resolve]       Server access error at url
> >>>>>
> >>>>>
> >> https://repo1.maven.org/maven2/org/apache/ant/ant-
> testutil/1.8.1/ant-
> >> testuti
> >>>>> l-1.8.1.pom
> >>>>> <
> >> https://repo1.maven.org/maven2/org/apache/ant/ant-
> testutil/1.8.1/ant-
> >> testutil-1.8.1.pom
> >>>>> (javax.net.ssl.SSLException: Received fatal alert:
> >>>>> protocol_version)
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>> AntLib - SVN
> >>>>>
> >>>>> same problem as for AU
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>> Ivy
> >>>>>
> >>>>> https://builds.apache.org/view/A/view/Ant/job/Ivy/
> >>>>>
> >>>>>
> https://builds.apache.org/view/A/view/Ant/job/Ivy/lastBuild/consol
> >>>>> e
> >>>>>
> >>>>> same problem as for AU
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>> Ant Nightly
> >>>>>
> >>>>> https://builds.apache.org/view/A/view/Ant/job/Ant_Nightly/
> >>>>>
> >>>>>
> >>>>>
> >>
> https://builds.apache.org/view/A/view/Ant/job/Ant_Nightly/lastBuild/c
> >> onsole
> >>>>> all runs fine, but "Archiving artifacts" requires loooot of time
> …
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>> Ideas?
> >>>>>
> >>>>>
> >>>>>
> >>>>> Jan
> >>>>>
> >>>>>
> >>
> >> --------------------------------------------------------------------
> -
> >> To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxx For
> additional
> >> commands, e-mail: dev-help@xxxxxxxxxxxxxx
> >>
> >>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxx For additional
> commands, e-mail: dev-help@xxxxxxxxxxxxxx



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxx
For additional commands, e-mail: dev-help@xxxxxxxxxxxxxx