git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [VOTE] Release 2.3.0-rc1 of Apache IvyDE


Everything looks good apart from the bug Ross reported which I have been able to reproduce. And it seems pretty consistent, not very random. And I see no error in Eclipse’s log.

I have been able to reproduce it with the Eclipse version:
Version: Neon.3 Release (4.6.3)
Build id: 20170314-1500

I am also using java 10, which is a bit tricky to make it run smoothly due to the modules thing. Maybe it is related.

And the project I tried to build in Eclipse is the Ivy project, which is about just an ivy.xml and a version.properties.

I know that the IvyDE code which is triggering the update of the classpath is tricky, it is quite sensible, partly due to the non trivial Eclipse APIs. Maybe with the last « cleanup » the resolve process has been messed up, and somehow it still work in the refresh case.

Since there is a work around (hitting refresh after resolve) and it is an RC, we could ship it like that and fix it later. But due to the automatic update via the update site, I bet most users will update even if it is an RC.
So I am not sure what I should vote.

So I vote -0 for me for now.

Nicolas

> Le 25 juin 2018 à 07:52, Jaikiran Pai <jai.forums2013@xxxxxxxxx> a écrit :
> 
> I'm initiating a newer vote mail for 2.3.0-rc1 release of Apache IvyDE project. This addresses the blocker issue that Nicolas identified, the last time a vote was initiated for this version.
> 
> The newly updated tag is here https://git-wip-us.apache.org/repos/asf?p=ant-ivyde.git;a=tag;h=refs/tags/2.3.0-rc1 with sha1 3581a61ec159ede16005f36e58e5e258d32090fa
> 
> You can download the distribution from this URL: https://dist.apache.org/repos/dist/dev/ant/ivyde/2.3.0-rc1/ at rev 27709
> 
> The Eclipse p2 repository is here: https://dist.apache.org/repos/dist/dev/ant/ivyde/updatesite/ivyde-2.3.0.rc1-201806251008-RELEASE/ at rev 27707
> 
> The 2.3.0-rc1 release of IvyDE consists of the following changes:
> 
> * FIX: xml bomb in workspace causes hang in Ivy code during Search or Synchronize operations (https://issues.apache.org/jira/browse/IVYDE-354)
> * FIX: Deadlock in classpath container (https://issues.apache.org/jira/browse/IVYDE-361)
> * FIX: Typo in IvyResolveJob (https://issues.apache.org/jira/browse/IVYDE-362)
> * FIX: User-selected configurations not checked in the viewer (https://issues.apache.org/jira/browse/IVYDE-378)
> * FIX: Fix ClassCastException (https://issues.apache.org/jira/browse/IVYDE-386)
> * FIX: Fix the issue where the IvyDE preferences couldn't be saved (https://issues.apache.org/jira/browse/IVYDE-388)
> 
> * NEW: Support for OSGi 'Bundle-Classpath' directive
> * NEW: Basic support for the workspace resolver to find OSGi bundles managed by Ivy in the workspace
> * NEW: Support for storing credentials securely
> 
> 
> Do you vote for the release of these binaries?
> 
> -Jaikiran
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxx
> For additional commands, e-mail: dev-help@xxxxxxxxxxxxxx
> 



( ! ) Warning: include(msgfooter.php): failed to open stream: No such file or directory in /var/www/git/apache-ant-development/msg02117.html on line 121
Call Stack
#TimeMemoryFunctionLocation
10.0015368664{main}( ).../msg02117.html:0

( ! ) Warning: include(): Failed opening 'msgfooter.php' for inclusion (include_path='.:/var/www/git') in /var/www/git/apache-ant-development/msg02117.html on line 121
Call Stack
#TimeMemoryFunctionLocation
10.0015368664{main}( ).../msg02117.html:0