git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [CANCELLED] Release AntUnit 1.4 Based on RC2


I think moving to Ant 1.8.x would be a better option, given the relatively low chances of it causing any issues.

-Jaikiran


On 21/06/18 2:47 PM, Stefan Bodewig wrote:
On 2018-06-21, Gintautas Grigelionis wrote:

POM template has inconsistent Ant versions, 1.7.1 in compile scope and
1.8.1 in provided scope.
True.

This happened in c3f8655 which updated the dependencies to 1.8.1 because
one of the unit tests used a method of ant-testutil that hasn't been
present in Ant 1.7.

We could fix the test or explicitly document Ant 1.8.x as new
requirement - which really doesn't exist except for the tests.

The upgrade would be a breaking change but I don't expect it would break
anything in real life. Some of the other antlibs may require Ant 1.7 but
the only other one I'd expect to get new releases (Compress) is at 1.8
already, so upgrading the dependency probably doesn't do any harm to
them.

Any opinions?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxx
For additional commands, e-mail: dev-help@xxxxxxxxxxxxxx



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxx
For additional commands, e-mail: dev-help@xxxxxxxxxxxxxx