git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[VOTE] Apache IvyDE 2.3.0-rc1 release


I have built a release candidate 2.3.0-rc1 for Apache IvyDE.

The tag is here: https://git1-us-west.apache.org/repos/asf?p=ant-ivyde.git;a=commit;h=refs/tags/2.3.0-rc1

You can download the distribution from this URL: https://dist.apache.org/repos/dist/dev/ant/ivyde/2.3.0-rc1

The Eclipse p2 repository is there: https://dist.apache.org/repos/dist/dev/ant/ivyde/updatesite/ivyde-2.3.0.rc1-201806132023-RELEASE/


This release consists of the following changes:

* FIX: xml bomb in workspace causes hang in Ivy code during Search or Synchronize operations (https://issues.apache.org/jira/browse/IVYDE-354) * FIX: Deadlock in classpath container (https://issues.apache.org/jira/browse/IVYDE-361) * FIX: Typo in IvyResolveJob (https://issues.apache.org/jira/browse/IVYDE-362) * FIX: User-selected configurations not checked in the viewer (https://issues.apache.org/jira/browse/IVYDE-378) * FIX: Fix ClassCastException (https://issues.apache.org/jira/browse/IVYDE-386)

* NEW: Support for OSGi 'Bundle-Classpath' directive
* NEW: Basic support for the workspace resolver to find OSGi bundles managed by Ivy in the workspace
* NEW: Support for storing credentials securely


Do you vote for the release of these binaries?

-Jaikiran


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxx
For additional commands, e-mail: dev-help@xxxxxxxxxxxxxx




( ! ) Warning: include(msgfooter.php): failed to open stream: No such file or directory in /var/www/git/apache-ant-development/msg02016.html on line 115
Call Stack
#TimeMemoryFunctionLocation
10.0007364576{main}( ).../msg02016.html:0

( ! ) Warning: include(): Failed opening 'msgfooter.php' for inclusion (include_path='.:/var/www/git') in /var/www/git/apache-ant-development/msg02016.html on line 115
Call Stack
#TimeMemoryFunctionLocation
10.0007364576{main}( ).../msg02016.html:0