git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Announce] Release of Apache Ivy 2.5.0-rc1


Thank you Nicolas for running this release.

-Jaikiran


On 22/04/18 11:24 PM, Nicolas Lalevée wrote:
The Apache Ivy project is pleased to announce its 2.5.0-rc1 release.

Apache Ivy is a tool for managing (recording, tracking, resolving and
reporting) project dependencies, characterized by flexibility,
configurability, and tight integration with Apache Ant.

Key features of this 2.5.0-rc1 release are
* The minimum runtime Java version required is now Java 7
* Ivy now uses BouncyCastle OpenPGP API 1.59. Due to the non backward compatibility of that library, earlier versions are not supported.
* Ivy now uses HttpComponents HttpClient 4.5.x version with HTTP backed resolvers. Users are expected to have this version of the library (and its dependencies) in their runtime classpath if they want to use such resolvers. The previous (similarly named but not the same) commons-httpclient library is no longer used or supported. (IVY-1563)

As a release candidate version, we strongly encourage the use of this version for
testing and validation.

Issues should be reported to:
https://issues.apache.org/jira/browse/IVY <https://issues.apache.org/jira/browse/IVY>

Download the 2.5.0-rc1 release at:
http://ant.apache.org/ivy/download.cgi <http://ant.apache.org/ivy/download.cgi>

More information can be found on the Ivy website:
http://ant.apache.org/ivy/ <http://ant.apache.org/ivy/>

Regards,
Nicolas Lalevée




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxx
For additional commands, e-mail: dev-help@xxxxxxxxxxxxxx