git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Will Airflow 2.0.0 support Python 2.7?


I think that many packages dropped support for Python 2.7 because they are depend on 3rd party packages which also dropped support.

Python 2.7 will be deprecated on 1-Jan-2020.
Assuming Airflow 2.0.0 will be released 1st/2nd quarter of 2019 it means that airflow 3.0.0 will have to be introduced 3rd/4th of 2019 quarter as dropping support for Python 2.7 can't be done in minor version...

Am I wrong?



‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Thursday, November 29, 2018 12:04 PM, Ash Berlin-Taylor <ash@xxxxxxxxxx> wrote:

> This came up previously, and no firm conclusion was released, but given Python 2.7 is still maintained for another year, yes, probably.
>
> > On 29 Nov 2018, at 08:48, airflowuser airflowuser@xxxxxxxxxxxxxx.INVALID wrote:
> > Are there plans to drop support for Python 2.7 - if so when ?