git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVE-2017-12614 XSS Vulnerability in Airflow < 1.9


CVE-2017-12614: Apache Reflected Reflected XSS Vulnerability

Vendor: The Apache Software Foundation:

Versions Affected: < 1.9

Description:
It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. Firefox and other browsers don't, and are vulnerable to this attack.

Mitigation:
The fix for this is to upgrade to Apache Airflow 1.9.0 or above

Credit:
This issue was discovered by Seth Long at Credit Karma


( ! ) Warning: include(msgfooter.php): failed to open stream: No such file or directory in /var/www/git/apache-airflow-development/msg04138.html on line 82
Call Stack
#TimeMemoryFunctionLocation
10.0006363160{main}( ).../msg04138.html:0

( ! ) Warning: include(): Failed opening 'msgfooter.php' for inclusion (include_path='.:/var/www/git') in /var/www/git/apache-airflow-development/msg04138.html on line 82
Call Stack
#TimeMemoryFunctionLocation
10.0006363160{main}( ).../msg04138.html:0