git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Apache Airflow 1.10.0b2


Marking as a blocker. When was this introduced?

B.

Verstuurd vanaf mijn iPad

> Op 21 jun. 2018 om 01:58 heeft Naik Kaxil <k.naik@xxxxxxxxx> het volgende geschreven:
> 
> It is working on the FAB UI after removing the old airflow.cfg file and running `airflow initdb`.
> 
> But with that the old webserver seems to be broken (Issue has already raised by Kevin here: https://issues.apache.org/jira/browse/AIRFLOW-2624).
> 
> Regards,
> Kaxil
> 
> On 20/06/2018, 22:35, "Naik Kaxil" <k.naik@xxxxxxxxx> wrote:
> 
>    Thanks Bolke.
> 
>    I have been testing this today and I see that the logs are not showing up for me in the Web UI (old UI using Flask Admin).
> 
>    The path of my log is: /Users/kaxil/airflow/logs/example_bash_operator/runme_0/2018-06-20T21:31:36.996580+00:00/1.log
> 
>    However, The log tab in the UI is blank and my guess is it is looking at a wrong path.
> 
>    I will test this for the new FAB UI as well and give you all an update.
> 
>    Regards,
>    Kaxil
> 
>    On 19/06/2018, 15:05, "Bolke de Bruin" <bdbruin@xxxxxxxxx> wrote:
> 
>        Hi All,
> 
>        I have rebranched v1-10-test today. I have created a sdist package that is available at:
> 
>        http://people.apache.org/~bolke/apache-airflow-1.10.0b2+incubating.tar.gz <http://people.apache.org/~bolke/apache-airflow-1.10.0b2+incubating.tar.gz>
> 
>        In order to distinguish it from an actual (apache) release it is:
> 
>        1. Marked as beta (python package managers do not install beta versions by default - PEP 440)
>        2. It is not signed
>        3. It is not at an official apache distribution location
> 
>        You can also put something like this in a requirements.txt file:
> 
>        git+
>        https://github.com/apache/incubator-airflow@v1-10-test#egg=apache-airflow[celery,crypto,emr,hive,hdfs,ldap,mysql,postgres,redis,slack,s3 <https://github.com/apache/incubator-airflow@v1-10-test#egg=apache-airflow[celery,crypto,emr,hive,hdfs,ldap,mysql,postgres,redis,slack,s3>]
>        <https://github.com/rodrigc/incubator-airflow@master#egg=apache-airflow[celery,crypto,emr,hive,hdfs,ldap,mysql,postgres,redis,slack,s3] <https://github.com/rodrigc/incubator-airflow@master#egg=apache-airflow[celery,crypto,emr,hive,hdfs,ldap,mysql,postgres,redis,slack,s3]>>
> 
>        and then "pip install -r requirements.txt”.
> 
>        Tomorrow I will do a beta 3, Friday I will kick-off an actual vote for release.
> 
>        Cheers
>        Bolke
> 
> 
> 
> 
> 
>    Kaxil Naik 
> 
>    Data Reply
>    2nd Floor, Nova South
>    160 Victoria Street, Westminster
>    London SW1E 5LB - UK 
>    phone: +44 (0)20 7730 6000
>    k.naik@xxxxxxxxx
>    www.reply.com
> 
> 
> 
> 
> 
> 
> Kaxil Naik 
> 
> Data Reply
> 2nd Floor, Nova South
> 160 Victoria Street, Westminster
> London SW1E 5LB - UK 
> phone: +44 (0)20 7730 6000
> k.naik@xxxxxxxxx
> www.reply.com