git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Duplicate Messages


In the default broker.xml since Artemis 2.5.0 you'll see a comment like
this above the acceptors:

         <!-- Note: If an acceptor needs to be compatible with HornetQ
and/or Artemis 1.x clients add
                    "anycastPrefix=jms.queue.;multicastPrefix=jms.topic."
to the acceptor url.
                    See https://issues.apache.org/jira/browse/ARTEMIS-1644
for more information. -->

This is also noted in the documentation for the 2.5.0 release [1].

Have you configured these prefixes when observing the problem?


Justin

[1] https://activemq.apache.org/artemis/docs/latest/versions.html#250

On Thu, Nov 1, 2018 at 9:26 AM Clebert Suconic <clebert.suconic@xxxxxxxxx>
wrote:

> On that case you must use prefixes on your 2.6.2 clients.
>
>
> Do you really need to mix 1.x and 2.x on this? I would keep things
> aligned on this case.
>
>
> But this is definitely related to your prefixes. When the client
> connects to the older version a new queue is being created, and that's
> causing your duplicate. It seems a configuration issue.
>
>
> If you really need to mix the versions.. you will need to play with
> prefixes.
> On Wed, Oct 31, 2018 at 4:31 PM ldebello <luis_debello@xxxxxxxxxxx> wrote:
> >
> > Hi Clebert,
> >
> > Thanks for your response, the issue is the other way around.
> >
> > - I have a Artemis Server 1.5.5 (In Cluster) using exclusive diverts. If
> the
> > client use the version 2.6.2 the message got duplicate.
> >
> > Let me know if I can provide more details on the issue.
> >
> > Thanks & Best Regards,
> > Luis
> >
> >
> >
> >
> > --
> > Sent from:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
>
>
>
> --
> Clebert Suconic
>