git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Three node Artemis cluster


What happens if you actually connect a consumer to node 1 or 2 and try to
consume those messages?  I'm not 100% certain what should be visible on the
management console of a node in the cluster when a queue is created on a
different node in the cluster, but I do know with your configuration
messages should be redistributed.  I would focus on tests that are actually
*functional* vs. just looking at the management console as we discussed in
IRC last night.  Of course, I'm assuming here that you actually want to
consume those messages and not just look at the console.

Regarding the AMQ224088 error message...Do you have any additional details
that you could share?  When is that message logged relative to the brokers
starting and the producer connecting?  Are any other clients on the network
attempting to connect to those ports on the broker?  That message is
typically only logged if something connects to the port where the broker is
listening and doesn't actually complete a protocol handshake.  Sometimes
security tools which scan ports can trigger this.  You might want to work
with your networking team to trace the incoming connections to the port
where the broker is listening.


Justin

On Mon, Jun 11, 2018 at 11:12 PM, schalmers <
simon.chalmers@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> wrote:

> Changes made:
>
> - Installed and created new brokers using Artemis v2.6.1 from
> https://github.com/apache/activemq-artemis/archive/2.6.1.tar.gz and then
> run
> mvn package and used the zip from apache-distribution/target
> - Modified broker.xml to fix up the cluster-connector (example broker.xml
> attached below as well)
> - Changed <message-load-balancing> to ON_DEMAND
> - Added <redistribution-delay>0</redistribution-delay> to <address-setting
> match="#">
>
> Observations:
>
> - Started all brokers; cluster came up fine with 3 nodes
> - All brokers are reporting this: ERROR
> [org.apache.activemq.artemis.core.server] AMQ224088: Timeout (10 seconds)
> while handshaking has occurred.
> - Connected to node3 and created 4 queues, sent 199 messages to queue
> update-terrain-leaf-bricks and 1 message to queue update-terrain-request
> (node3.png screenshot attached).
> - On node1, only one of the 4 queues from node3 was created:
> update-terrain-response (node1.png screenshot attached).
> - On node2, no queues were created (node2.png screenshot attached).
>
> Broker.xml:
> broker.xml <http://activemq.2283324.n4.nabble.com/file/t378947/broker.xml>
>
>
> Node3 screenshot:
> node3.PNG <http://activemq.2283324.n4.nabble.com/file/t378947/node3.PNG>
>
> Node2 screenshot:
> node2.PNG <http://activemq.2283324.n4.nabble.com/file/t378947/node2.PNG>
>
> Node1 screenshot:
> node1.PNG <http://activemq.2283324.n4.nabble.com/file/t378947/node1.PNG>
>
>
>
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-
> f2341805.html
>